CakePHP-Fr.Org

Forum francophone du Framework CakePHP

Vous n'êtes pas identifié.

#1 24-09-2013 16:10:43

Mokette
Eclair café
Date d'inscription: 26-06-2012
Messages: 48

Problème avec DebugKit

Bonjour,

je me heurte à un petit problème quand je passe mon site en production,
je me retrouve avec cette erreur

Code: php

  1. Parse error: syntax error, unexpected T_FUNCTION app/Plugin/DebugKit/Controller/Component/ToolbarComponent.php on line 182

J'ai la dernière version du plugin et cakephp version 2.3.8

Cependant là ou j'ai un problème c'est que sur mon serveur je n'ai que la version 5.2.17 de php, or je sais que pour le dernier DebugKit il faut forcément une version de php égale ou supérieur à 5.3.

Existe-t-il une version de DebugKit compatible avec un cakephp 2.3 et la version 5.2 de php ?
Sur le githup de debugkit il est juste précisé la version minimale requise de cakephp et ce n'est pas précisé pour la version de php (excepté pour la dernière version de debugkit ou dans les prérequis c'est précisé php 5.3 ou supérieur)

Parce qu'il semblerait que je ne puisse pas mettre à jour la version de php sur le serveur :s

Même en mettant :

Code: php

  1. SetEnv PHP_VER 5_4

dans mes htaccess, cela ne résoud pas le problème hmm

Si quelqu'un a une idée, je le remercei d'avance smile

Cordialement,

Mokette

Dernière modification par Mokette (24-09-2013 17:06:11)


If someone ask, i'm not here !! ^^

GnomeBusters  ||  Invictus-Fortes

Hors ligne

 

#2 11-04-2014 17:07:36

sammnrve
Brownie
Date d'inscription: 28-02-2011
Messages: 29

Re: Problème avec DebugKit

bonjour

juste pour mon information, tu passe tes sites en production avec une possibilité de passer ton site en debug ???

dangereux :'(

je pense que la solution est de ne pas livrer debug_kit en production.


A quoi sert le savoir si il n'est pas partagé

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr