CakePHP-Fr.Org

Forum francophone du Framework CakePHP

Vous n'êtes pas identifié.

#1 18-06-2015 16:16:47

mansaychai
Brownie
Date d'inscription: 27-03-2015
Messages: 24

[RESOLU] - Déploiement CakePHP3 | seule la page d'accueil fonctionne

Bonjour à tous,

J'ai mis mon site en ligne sur mon VPS perso de chez OVH.

J'arrive à récupérer ma page d'accueil, layout + contenu !
Cependant, lorsque je clique sur n'importe lequel des liens, je récupère le layout et une erreur "Error: An Internal Error Has Occurred" où devrait être mon contenu.

Dans l'inspecteur Firefox, j'ai une belle erreur 500. Le vue correspondant au lien sur lequel on clique n'est donc pas chargé ...
Peut-être un problème d'url rewriting ?

Si quelqu'un à une piste pour me débloquer, il est le bienvenue big_smile !

Dernière modification par mansaychai (20-06-2015 11:25:04)

Hors ligne

 

#2 19-06-2015 12:38:11

cyberbobjr
Baker
Date d'inscription: 13-07-2010
Messages: 625

Re: [RESOLU] - Déploiement CakePHP3 | seule la page d'accueil fonctionne

Mets debug=true dans core.php, tu auras l'erreur precise


Développeur freelance et disponible, contactez-moi en privé.
Mon blog CakePHP : http://caketuts.key-conseil.fr

Hors ligne

 

#3 20-06-2015 11:22:20

mansaychai
Brownie
Date d'inscription: 27-03-2015
Messages: 24

Re: [RESOLU] - Déploiement CakePHP3 | seule la page d'accueil fonctionne

Bonjour cyberbobjr,

Effectivement je l'avais passé à false comme indiqué dans la doc', donc pas facile de se débrouiller avec une erreur page blanche.
Ce n'était pas grand chose finalement, l'accès à la bdd foirait. J'avais fait une erreur bête dans la config, rien de méchant !

Merci encore !

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB
Traduction par FluxBB.fr